I’ve got lots to blog about, but I’ve been too busy playing with new toys to get around to it. This is just a quick note for the internets.

Running Xen on Debian Etch on a machine with 4gb of ram, if you get

"PAE mode mismatch error (xen=yes dom0=no)"

you need to install:

apt-get install xen-hypervisor-3.0.3-1-i386-pae

as the default xen kernel now enables pae by itself when necessary, and the default hypervisor doesn’t support it.