I have a cheap Chinese made adjustable bench power supply at home that I bought during a group by at my local hackerspace. It does 0-18V up to 3A and came in at $60, as a budding electronics tinkerer it was pretty hard to say no to that.

One of the things I’ve learned about cheap Chinese powersupplies during my research (read: watching youtube videos) is that they usually have a fair amount of overshoot when you turn them on. In the case of mine I can turn it off when set to +12V, and when I turn it back on it’ll hit +16V before settling down.

I set out today to fix that and about half-way though adding a new power switch to the back of the unit and repurposing the original switch as a load-switch I noticed a 3-wire cable that goes from the board that has the adjustment controls to the board that houses the output jacks. I had a hunch that the controller board may be using that 3-wire cable to read the actual output voltage of the unit. I then realised my clever plan would need ammending. I realised that I’m going to need to tie in the +V sense line before my new load-switch instead of after the switch where it is now. Well, I figured that’s what it meant. I decided to close up the patient according to the original plan, partially because I wanted to see if I was correct and mostly because I was really tired of using my ancient ratshack soldering station. I was especially tired of using it as I know my new rework station will be here either Monday or Tuesday.

After putting everything back together I verified the new power switch works properly. Lights on. Lights off. Lights on. Lights off.

Lights on. Now we test the load switch. Load off. Aaaaand the voltage display disappears and the powersupply drops into constant current mode. We’re going to need to move that voltage sense line. Good to know. It’ll be easy to do. I’m not going to bother until the radioshack soldering iron is in the garbage.

I didn’t accomplish what I set out to, but at least I learned something along the way.